Comcast/Xfinitiy Internet Outage - Unplanned Maintenance
Incident Report for PIP Metro Indy
Postmortem

We apologize for any inconvenience caused by this unexpected downtime. We were closely monitoring the Comcast outage map during this time in hopes for an update.

During incidents where our email or phone lines are down, the team can still be reached via email for any urgent matters or questions.

Posted Jul 10, 2023 - 15:14 UTC

Resolved
We are experiencing long-term internet outages from the large storms that are affecting our phone lines, computers, and printers. We will be closely monitoring the outage map for updates from Comcast. We are currently unable to process new orders in the meantime.
Posted Jun 20, 2023 - 13:00 UTC